Tutorials/Audacity/Tutorial

From Bjoern Hassler's website
Jump to: navigation, search

This tutorial was written in October 2007, and was for Audacity 1.3.4. The tutorial was used in the context of a podcast course, where students were given a special zip file that contained audacity apps for windows and mac. Also, the version of audacity was modified to include some special features. These were also contributed to the audacity project, and are now all included in the main build of Audacity.

1 THREE IMPORTANT RULES FOR NOT LOOSING YOUR WORK[edit]

(a) When starting a new project, always save your blank project first, before you start working. (Otherwise the auto-recovery fails.)

(b) Always make a 'surrounding folder', in which you save a particular project. Then when moving your project, move the 'surrounding folder'. Never just move the '.aup' file.

(c) If Audacity crashes unexpectedly, read the 'auto recovery' section below. You may be able to recover your work.

2 STARTING AUDACITY[edit]

From the downloaded zip file, select "Audacity applications".

Audacity Tutorial 01 Open Application.png


To use Audacity on a recent Apple Mac, select Audacity-IntelMac:

Audacity Tutorial 002 Audacity format.png


To use Audacity on a PC using Windows, select Audacity-Win.exe:

Audacity Tutorial 03 Audacity format.png


Once Audacity has opened you should have the usual Audacity project view in front of you.

Audacity Tutorial 04 Audacity new screen .png


Select File > Open.

Audacity Tutorial 05 Open.png


Within the open file dialogue select "Podcast Course", "Audacity projects", "First Project".

Audacity Tutorial 06 First Project.png


Within first project you then need to select the "FirstProject.aup" file.

Audacity Tutorial 07 First Profect File.png


This will open your project ready with tracks available to work on.

Audacity Tutorial 08 Project screen.png


You'll notice that the project sounds like a mess - your task is to sort out the audio in the project to sound reasonable!

3 Saving a project[edit]

IMPORTANT: Notice how there was a surrounding folder 'FirstProject" when you opened the project:

Audacity Tutorial 09 First Profect File.png

If you save your project, you must first create a folder, e.g. "My second project", and then save the audacity file into this folder, e.g. with filename "My second project.aup". You'll notice that Audacity is creating an additional folder next to your ".aup" file, called "My second project_data". Your project won't work without that folder. Hence you must always move your ".aup" file and the "_data" folder around together. The best way of doing this is to create a 'surrounding folder', i.e. "My second project", and then save the audacity project into this.

Then, if you want to move the project, you just move the folder "My second project", and all is fine.

This is very important - please let us know if this description is unclear!


4 TOOL MENU[edit]

The tool keys from F1 to F6 allow you to turn the cursor into different tools. The two important tools are "F1" which is the "selection tool". This allows you to change your cursor to be able to select audio, change the timeline position and highlight audio.

Audacity Tutorial 10 LinkBack Item from OmniGraffle.png


The "Hand" tool (☞and☜) is a cursor that appears when using the "selection tool". It appears when the cursor is hovering over the edge of a highlighted area and can be used to extend or contract the highlighted area. It can also extend the highlighted area vertically to other tracks.

The other important tool key is "F5": this allows you to change your cursor to the "Time shift tool". The time shift tool allows you then to move sections of audio with the cursor along the timeline. The image shows the time shift tool. Try grabbing an audio clip with the time shift tool, and moving it along in the same track, or to a different track!

Audacity Tutorial 11 LinkBack Item from OmniGraffle.png


5 IMPORTING AUDIO FILES INTO AUDACITY[edit]

Read this section if you want to import files into audacity - you can skip ahead to the next section on a first read!

You can also import files into Audacity if you want to add to your project. To do this select File > Import

Audacity Tutorial 12 Import.png


Then select audio

Audacity Tutorial 13 Import Audio.png


This will bring up the file import dialog for which file you want to import and from where.

Audacity Tutorial 14 Import options.png


Select your file and click open.

Audacity Tutorial 15 Open file.png


Alternatively you can save an audio file to the desktop and drag the file from the desktop into Audacity as shown. However if your file is in a format Audactiy does not recognise it will not open. Audacity will generally not recognised windows media audio/video (wma/wmv), realaudio/video (ra, rm). It will recognised mp3, aiff, and wav.

Audacity Tutorial 16 Dragging in.png Audacity Tutorial 16 OpeningDocsMac.png


When the file is imported you will see a track form with the wave file within it.

Audacity Tutorial 17 Wave form.png


The ruler along the toolbar running with the track is the audio timeline and shows the track times in minutes and seconds.

Audacity Tutorial 18 Timeline.png

6 PLAYING YOUR AUDIO AND NAVIGATION[edit]

We will first look at how to play your audio file. To play your audio file either use the keyboard short cuts or alternatively select the option you want from the play menu. Although we'll give you the equivalent menu commands, it's best to get used to the keyboard shortcuts as quickly as possible. Consult the keyboard map.

Alternative keyboard short cuts for playing audio are space and return, "Space" will play and (when pressed again) stop playback. However, when you stop playback, the play position will return to the point from where you started. "Return" will play and stop, but at the position where you pressed return. Explore the function of both keys!

You can also start/stop playback through the buttons in the play menu.

Audacity Tutorial 19 Tool Bar.png


There are many easy ways of playing and skipping around in your project.

When playback is stopped, the arrow keys "left" and "right" allow you to move forward and backwards along the timeline in small increments. When the audio is playing you can again use the arrow keys to skip back or forward a second at a time and the audio will continue to play from the point you have skipped to.

Whether playing or stopped: To skip left 1 sec you can press ",". If you hold the key down and it will scroll through your project leftwards. To skip right 1 sec press ".". Again if you hold it down it will scroll forward. If you need to jump or scroll in larger increments, you can press "Shift-," to skip left 15 secs, and likewise press "Shift-." to skip right 15 secs.

You can also easily skip from any point straight to the beginning of your audio or right to the end. To skip back to the beginning simply press "HOME". To skip straight to the end press "END".

7 THE VIEW MENU (ZOOM)[edit]

To zoom in on a selected area of audio place the cursor on the area you wish to zoom in on and press the "=/+" button, however much you wish to zoom in or select "View > Zoom in". You can also zoom out by pressing the "-" button or select "View > Zoom out". If you have been zooming in and out a lot you can get the screen back to normal you by pressing "0" and this will take you back to a normal view. You can also select this option from the View menu.

Audacity Tutorial 20 Zoom In.png Audacity Tutorial 21 Zoom out.png Audacity Tutorial 22 Zoom Normal.png


The image shows a project closely zoomed in on the waveform:

Audacity Tutorial 23 Zoomed in .png


The same project, zoomed out further:

Audacity Tutorial 24 Zoomed out.png


If you have an area selected that you wish to zoom into you can press "e" or select "View > Zoom To Selection".

Audacity Tutorial 25 Zoom to Selection.png


The selection now fills the project view left to right:

Audacity Tutorial 26 Zoom to Selection.png


Equally as useful you can also make the audio tracks you are working on fit to the window both vertically and horizontally. To fit your audio to the window horizontally simply press "f" or select "View > Fit in window".

Audacity Tutorial 27 Fit in Window.png


Audacity Tutorial 28 Fitted in Window.png


To fit your audio in the window vertically press "Shift-F" or "View > Fit Vertically".

Audacity Tutorial 29 Fit Vertically.png


Audacity Tutorial 30 Fitted Vertically.png




8 THE "GENERATE" MENU[edit]

You are also able to generate different audio from the toolbar from "chirps" to "tones". For example, simply go to "Generate > Tone". It will then ask you the frequency, amplitude and length you wish to generate, which you can adjust. The tone will generate on the track selected.

Audacity Tutorial 31 Generate Menu.png

9 Making a new track[edit]

Firstly create a new track within your project. To do this you need to select "Tracks > Add New".The type of track will vary but for now choose audio track.

Audacity Tutorial 32 Adding New Track.png


Your new track will then be within your project as a blank track. This spare track is very useful to be used as a storing bin for any temporarily unwanted audio, that is easily put back into the project. To put unwanted audio onto the spare track you can simply use the shift tool (F5) to move it there.

Audacity Tutorial 33 New Track Added.png


10 MAKING AND CHANGING SELECTIONS[edit]

IMPORTANT TIP: The following will only work if you have selected a track. When a track is selected it will be surrounded by a yellow box, visible int the images below as thin yellow lines above and below the track. This is the same for some editing tools and not others so if you are having problems double check that the yellow box is surrounding the track you want. To get a yellow box, just click near the end of a track, or in the space below tracks.

You can make a selection using the mouse, or using the "[" and "]" key.

Using the mouse. Mark an area by swiping over it with the mouse.

Using the keyboard, there are simple and easy ways to either select an area of audio when stopped or while playing. Try pressing "[" and then later "]" while you are playing back, and you'll see a selection being marked.

Alternatively, when stopped, press "]" to begin highlighting right from the cursor point and press "[" to begin highlighting left from the cursor point. If you already have a selection, "[" and "]" will extend the selection.

Also, when you're near the edge of the selection with the cursor, the cursor turns into the "hand" symbol you can then drag a highlighted area using the mouse.

Audacity Tutorial 34 Extend Right.png Audacity Tutorial 35 Extend Left.png


You can also contract the highlighted area by simple pressing "Shift" and either "[ or ]" depending on the direction you want to contract.



11 THE "EDIT" MENU - EDITING YOUR AUDIO FILE[edit]

With your audio file on the timeline, having made a selection, you can begin to edit the track. Using both the Keyboard shortcuts and toolbar options you can edit your track in the way you want too.

You can cut and paste, just like you do in a word processor. To cut a selected area of audio simply highlight the area you wish to cut using the mouse (details above). Then press "Ctrl-X" or choose "Edit > Cut".

Audacity Tutorial 36 Cut.png


Audacity Tutorial 37 Highlighted Track.png


To paste a selected piece of audio you can again either use "Ctrl-V" or "Edit > Paste". The selected audio will appear on the timeline in the track that is selected. The audio is pasted in at starting at the position of the timeline marker.

Audacity Tutorial 38 Paste Before.png Audacity Tutorial 39 Paste After.png


Alternately to cutting a selected piece of audio, you can also copy audio, using the same technique. Simply highlight the selected audio with the cursor, then press "Ctrl-C" or "View > Copy" and again paste the audio in the same way as cutting.

Audacity Tutorial 40 Copy.png Audacity Tutorial 41 Paste.png


You can also trim a piece of audio to get rid of any extra audio or unwanted surrounding sounds so to do this you need to highlight the area you wish to keep press "Ctrl-T" or "Edit > Trim".

Audacity Tutorial 42 Trim Before.png Audacity Tutorial 43 Trim After.png


You also have the ability to split a piece of audio into different sections. This enables you to work on the sections separately adding fades or other effects to the audio. This is a useful tool when interviewing as you can split the interview into each question. To split audio either press "Ctrl-I" or "Edit > Split".

Audacity Tutorial 44 Split Before.png Audacity Tutorial 45 Split After.png


12 Edit Menu: Undo and Redo[edit]

Whilst editing if you find you have made a mistake or accidentally deleted a piece of audio you can easily retain it by using the undo option. To undo you can either press "Ctrl-Z" or "Edit > Undo".

Audacity Tutorial 46 Undo Before.png Audacity Tutorial 47 Undo After.png


If you undid something you then realise was okay similiarily you can redo the selections you had undone. To do this simply either press "Shift-Ctrl-Z" or "Edit > Redo".

Audacity Tutorial 48 Redo Before.png Audacity Tutorial 49 Redo After.png


13 CRASH RECOVERY[edit]

Like with many other software, Audacity can occassionally crash. Fortunately there is a recovery option, that allows you to recover unsave worked after crashes. When Audacity crashes, first make sure that Audacity has really crashed, and you cannot see any open Audacity windows. Then reopen audacity. You may see the following error message. Make sure Audacity is not running then select yes.

Audacity Tutorial 50 Temporary file error..png


We will show you later how to remove this message.

A crash recovery screen will now appear, with Audacity giving you the option to recover you project. Select recover projects and this will load the projects you were using before the crash.

Audacity Tutorial 51 Crash Recovery.png


Once the project is back running to save your work.

14 Crash recovery: Removing the "lock file"[edit]

If Audacity crashed, you might keep seeing the message below every time Audacity starts. Here is how to fix this.

Audacity Tutorial 52 Temporary file error..png


If the "error locking temporary folder" keeps re-appearing, you need to remove a particular file, called a "lock file". To do this enter "Podcast course" > "Audacity Applications", and then the "Temporary" folder. Go to "Audacity_temp". You should see a file called "audacity-lock-username". Delete this file, either using "Backspace/Delete" or dragging the file into the "Trash".

Audacity Tutorial 53 Temporary folder.png


Audacity Tutorial 54 Temporary File Deleted.png


The "Audacity_temp" folder should now be empty and next time you start audacity the error message will not appear.

15 License[edit]

This document is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License. http://creativecommons.org/licenses/by-nc-sa/3.0/Creative. Please acknowledge Björn Haßler (http://www.sciencemedianetwork.org), Gail Pearson, and Andrew Taylor, as well as any additional authors on the ICT4E wiki. Original document written 29th November 2007.